Opened 8 years ago

Closed 8 years ago

#12252 closed defect (fixed)

[regression] RTL: missing right border on ComboBox arrow buttons in 1.6 betas

Reported by: Kenneth G. Franqueiro Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit - LnF Version: 1.6.0b1
Keywords: rtl Cc:
Blocked By: Blocking:

Description

If you look at e.g. http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect&dir=rtl you will notice that the right side of the drop-down arrow button is missing its border. This looked fine in 1.5, seems to be missing in all browsers on 1.6 beta 1 and 2.

It seems as if the culprit is the styles added to dijit_rtl.css in [22885]; not sure what the reason behind that addition was.

Change History (3)

comment:1 Changed 8 years ago by bill

Owner: set to Jared Jurkiewicz

That is mysterious code added in [22885]:

.dijit_a11y .dijitToolbar .dijitTextBoxRtl .dijitValidationContainer,
.dijitTextBoxRtl .dijitSpinnerButtonContainer,
.dijitComboBoxRtl .dijitArrowButtonContainer  {
	border-right-width: 0 !important;
	border-right-style: none !important;
}

Jared, can we just remove that whole thing? It contradicts the rule above it.

comment:2 Changed 8 years ago by Jared Jurkiewicz

Owner: changed from Jared Jurkiewicz to bill

That was added by Katy to fix issues witht the dropdown border/enablement when used in dijit toolbars, such as in the dropdowns used in font choice by Editor. Feel free to remove it, but verify that it doesn't break the dropdowns in editor.

comment:3 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

(In [23741]) Fixes to the border between ComboBox's input area and arrow icon:

  • border wasn't showing up in RTL mode (it should)
  • border was showing up for a ComboBox in a Toolbar (it shouldn't, ComboBoxes in Toolbars have special styling)

Also removed some unneeded a11y rules, though there are still unnecessary rules left, setting border color and width.

Fixes #12252.

Note: See TracTickets for help on using tickets.