Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#12247 closed defect (fixed)

[patch]Cannot resize column in DataGrid in IE8

Reported by: soularis999 Owned by: Bryan Forbes
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.4.3
Keywords: dojox.grid.DataGrid Cc: [email protected]
Blocked By: Blocking:

Description

The example is provided. I defined the grid layout in html (as table and th attributes). Each th has a width defineds. After the grid is rendered I can increase the width of the column but cannot decrease it in IE8.

Attachments (3)

gridtest.html (1.4 KB) - added by soularis999 10 years ago.
gridtest.json (391 bytes) - added by soularis999 10 years ago.
12247.patch (583 bytes) - added by evan 10 years ago.
Patch from Gino Andres Caverzan(IBM, CCLA), this issue is caused by negative value of 'sw' set to node.style.width, in IE, an exception is thrown.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by soularis999

Attachment: gridtest.html added

Changed 10 years ago by soularis999

Attachment: gridtest.json added

comment:1 Changed 10 years ago by soularis999

One more thing. Seems that if you do not provide the column width for your grid layout, the resize works correctly...

comment:2 Changed 10 years ago by evan

Cc: [email protected] added
Summary: Cannot resize column in DataGrid in IE8[patch]Cannot resize column in DataGrid in IE8

Changed 10 years ago by evan

Attachment: 12247.patch added

Patch from Gino Andres Caverzan(IBM, CCLA), this issue is caused by negative value of 'sw' set to node.style.width, in IE, an exception is thrown.

comment:3 Changed 10 years ago by Bryan Forbes

Owner: changed from bryanforbes to Bryan Forbes

comment:4 Changed 10 years ago by Bryan Forbes

(In [24060]) Applied patch to fix resizing in IE8. refs #12247 !strict

comment:5 Changed 10 years ago by Bryan Forbes

(In [24061]) Applied patch to fix resizing in IE8 (backported to 1.6 branch). refs #12247 !strict

comment:6 Changed 10 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

comment:7 Changed 10 years ago by bill

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.