Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12243 closed defect (worksforme)

IE9: dijit._frames.pop dies in IE-specific branch

Reported by: Kenneth G. Franqueiro Owned by:
Priority: high Milestone: 1.5.2
Component: Dijit Version: 1.6.0b1
Keywords: IE9 popup Cc:
Blocked By: Blocking:

Description

This is reproducible in likely several places; easiest I found to isolate was in dijit/tests/form/test_Button.html.

Essentially any code that involves creating a popup (e.g. hovering on the first Create button which has a Tooltip, or trying to open the drop-down on the combo button) will die with "DOM Exception: INVALID_CHARACTER_ERR (5)".

At first blush, it appears that amending the UA check in dijit/_base/popup.js line 314 to (dojo.isIE < 9) resolves the issue, but I'm unsure if there may be side effects to taking the other path.

Tested with IE9 RC.

Change History (7)

comment:1 Changed 9 years ago by Kenneth G. Franqueiro

Resolution: fixed
Status: newclosed

(In [23718]) Exclude IE9+ from special codepath in dijit._frames.pop, fixes #12243.

comment:2 Changed 9 years ago by Kenneth G. Franqueiro

Resolution: fixed
Status: closedreopened

It seems like this change isn't the solution after all - after glancing at a couple other pages (including test_bgIframe.html) it becomes apparent that this actually killed BackgroundIframe in IE9.

comment:3 Changed 9 years ago by Kenneth G. Franqueiro

After further investigation, it seems that iframes don't "protect" flash/applet areas in IE9 as they did in previous versions. Thus the finding in my previous comment might be a red herring - but then do we consider this an open issue or not?

comment:4 Changed 9 years ago by Kenneth G. Franqueiro

After further further investigation, the official RC seems to have resolved the issue about iframes not appearing in front of flash objects. I'd like to assume the same for applets but I can't test it as applets seem to have a high tendency to crash the tab in IE9. But I think this ticket might indeed be closable.

comment:5 Changed 9 years ago by Kenneth G. Franqueiro

Resolution: worksforme
Status: reopenedclosed

Everything seems to be working fine on IE9 final, re-closing.

comment:6 Changed 9 years ago by Kenneth G. Franqueiro

Milestone: tbd1.6

comment:7 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: 1.61.5.2

Updating milestone to 1.5.2 to reflect inclusion in changeset [26956] for ticket #14199.

Note: See TracTickets for help on using tickets.