Opened 8 years ago

Closed 4 years ago

#12235 closed defect (duplicate)

MultiComboBox multi selection does not work as expected

Reported by: j105rob Owned by: dante
Priority: high Milestone: 1.11
Component: DojoX Form Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

The example here: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/form/tests/test_MultiComboBox.html

Does not work as expected or as documented.

Steps to recreate issue:

  1. Type in letter 'a'; hit enter
  2. Type in default delimiter ',';
  3. Type in letter 'a';

Problem is that when the user selects an entry that starts with a specific letter, such as 'a' for 'accounting', then selects that value (accounting), then enters a delimiter, then begins to select another value that starts with the same letter ('a' for 'atv'), the selection box resets.

Even if the user selects something like 'accounting,backcountry,' then selects 'atv' the box resets.

This issue was discovered by ceven on the IRC. I am reporting it for ceven.

Change History (1)

comment:1 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: duplicate
Status: newclosed

Duplicate of #7932.
Duplicate of #7932

Note: See TracTickets for help on using tickets.