Opened 9 years ago

Closed 8 years ago

#12224 closed defect (duplicate)

Grid scoll position reset to top in Webkit browsers when grid resized or rerendered

Reported by: ccalvert Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.5
Keywords: scroll, WebKit, Chrome, Safari Cc:
Blocked By: Blocking:

Description

Steps to reproduce:

  1. Using Safari or Chrome, go to http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test_grid.html
  1. Scroll down to near the bottom
  1. Click on a column header to sort the grid by that column.

Expected behavior: the scrolling position will be maintained. This is seen in IE 8 and Firefox 3.6.

Actual behavior: In Safari 4 and Chrome 8 (both based on WebKit?), the grid is scrolled back to the top.

Cause: dojox/grid/_View.js line 206:

this.scrollboxNode.style.height = ;

In the WebKit? based browsers, this causes the unexpected behavior. Commenting out the line eliminates the behavior, but I have not done any regression testing to see if it causes problems elsewhere.

Change History (2)

comment:1 Changed 9 years ago by Bryan Forbes

Owner: changed from bryanforbes to Bryan Forbes

comment:2 Changed 8 years ago by Bryan Forbes

Resolution: duplicate
Status: newclosed

Duplicate of #7273.
I've added the information here to #7273.

Note: See TracTickets for help on using tickets.