Opened 13 years ago

Closed 13 years ago

#1220 closed defect (duplicate)

onClose event is not invoked when I close a "dynamically created" Tab (both in IE & Mozzila)

Reported by: kmondal@… Owned by: anonymous
Priority: high Milestone:
Component: Core Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

Hi Gurus, I am using Dojo since last 1 month. My goal is to create a tab dynamically and when user will close the tab, I have to process something as part of tab's close event. The related code is listed below:

. . .

function testClose(pane,tab) {

return confirm("Please confirm that you want tab "+tab.label+" closed");

} . . . .

var tabTitle = "A CLOSABLE TAB";

var tabContainer = dojo.widget.byId('mainTabContainer');

var newTab = dojo.widget.createWidget("ContentPane?", {id:"Tab 11", label:tabTitle, onClose:"testClose" });

tabContainer.closeButton="tab";

tabContainer.addChild(newTab);

tabContainer.selectTab(newTab);

. .

My problem is: the testClose() function does never get called at all !! Same thing happens in IE & Mozzila.

Any help will be highly appreciated.

Thanx, Kuntal

Change History (1)

comment:1 Changed 13 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of [1219]

Note: See TracTickets for help on using tickets.