Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12195 closed defect (fixed)

[regression]Date picker cell with Datagrid

Reported by: Eric Pasquier Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.6.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

A simple double click doesn't open the Date picker in a Datagrid cell anymore. Instead, you get an empty combo box, and you have to click one more time to open the Date picker.

Attachments (1)

testdate3.htm (3.5 KB) - added by Eric Pasquier 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Eric Pasquier

Attachment: testdate3.htm added

comment:1 Changed 9 years ago by evan

Component: GeneralDojoX Grid
Owner: changed from anonymous to evan

comment:2 Changed 9 years ago by evan

Resolution: fixed
Status: newclosed

(In [23651]) Fixes #12195, font color shouldn't be #fff which makes text box or other editable widgets look like empty.

comment:3 Changed 9 years ago by evan

Milestone: tbd1.6

Caused by soria theme, when row over the Date Text Box, the font color is changed to white and this make the widget look like empty.

With the fix now the behavior of testdate3.htm is the same as test_edit_dijit.html

comment:4 Changed 9 years ago by Eric Pasquier

Thanks for the fix ! It is easier to understand the use of the new dropdown button. To be complete, I also tested claro and nihilo themes, as test_edit_dijit.html is using tundra, and they are working correctly (but you may have done the same tests).

Note: See TracTickets for help on using tickets.