Opened 9 years ago

Closed 8 years ago

#12180 closed defect (fixed)

Dojo charting raises exception when data series is all zeros

Reported by: sbrooks Owned by: Eugene Lazutkin
Priority: high Milestone: 1.8
Component: Charting Version: 1.6.0b1
Keywords: charting, axis, exception, max Cc: cjolif
Blocked By: Blocking:

Description

A javascript exception is raised when I add a series consisting of all zeros, e.g. [0, 0, 0, 0, 0, 0, 0] to a chart. I saw the problem with both dojo version 1.4 and 1.5. The exception was the same in both cases "t is null", referring to the line: dojo.forEach(t.major, function(tick){ ...

In dojo 1.4 this line is in dojox.charting.widgets.Chart2D.js, on line number 7173 in the uncompressed source.

In dojo 1.5 this line is in dojox.charting.axis2d.Defaut.js, on line number 501 in the uncompressed source.

All I have to do to avoid the problem is make one of the data values in the series non-zero.

If I set a min and max value for the y axis, then the problem is not seen, however, the setting of min and max values should be optional.

Browser: Firefox 3.6.13 OS: Windows 7

Change History (4)

comment:1 Changed 9 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned

comment:2 Changed 8 years ago by cjolif

Cc: cjolif added

comment:3 Changed 8 years ago by Mathevet julien

It seems fixed in trunk

comment:4 Changed 8 years ago by cjolif

Milestone: future1.8
Resolution: fixed
Status: assignedclosed

It is fixed indeed in 1.8. Thanks.

Note: See TracTickets for help on using tickets.