Opened 9 years ago

Closed 9 years ago

#12170 closed defect (fixed)

[patch][ccla]Bars&Columns do not display correctly in Firefox3.5

Reported by: ruanqi Owned by: Eugene Lazutkin
Priority: high Milestone: 1.6
Component: Charting Version: 1.6.0b1
Keywords: firefox3.5, bars, columns, collectSimpleStats Cc: Adam Peller, rqruanqi@…
Blocked By: Blocking:

Description

Bars and Columns do not display correctly in Firefox3.5(see attached screen shot), it turns out that collectSimpleStats() in plot2d/common.js did return the right "stat" value. This issue can not be reproduced by debugger mode(very weird...).

PS: The testcase is charting/tests/test_chart2d.html

Attachments (5)

bar_ff35.png (2.3 KB) - added by ruanqi 9 years ago.
Bars Chart in firefox3.5
bars.png (2.8 KB) - added by ruanqi 9 years ago.
correct bars chart
columns_ff35.png (3.0 KB) - added by ruanqi 9 years ago.
columns.png (4.8 KB) - added by ruanqi 9 years ago.
bar_column_ff3.5.patch (605 bytes) - added by Adam Peller 9 years ago.
patch from Rock (IBM, CCLA)

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by ruanqi

Attachment: bar_ff35.png added

Bars Chart in firefox3.5

Changed 9 years ago by ruanqi

Attachment: bars.png added

correct bars chart

Changed 9 years ago by ruanqi

Attachment: columns_ff35.png added

Changed 9 years ago by ruanqi

Attachment: columns.png added

Changed 9 years ago by Adam Peller

Attachment: bar_column_ff3.5.patch added

patch from Rock (IBM, CCLA)

comment:1 Changed 9 years ago by Eugene Lazutkin

Priority: highnormal
severity: criticalnormal
Status: newassigned

I cannot reproduce the bug, and the patch doesn't do anything --- it defines the same properties with the same values, but in a different mode. Theoretically the patch has no effect. But if it helps you in some way, I don't see why not commit it. ;-)

comment:2 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [23689]) charting: voodoo fix for a weird bug, thx Rock (IBM, CCLA), !strict, fixes #12170.

Note: See TracTickets for help on using tickets.