Opened 9 years ago

Closed 7 years ago

#12151 closed defect (fixed)

dojo.Deferred docs missing

Reported by: Adam Peller Owned by: Neil Roberts
Priority: high Milestone: 1.8
Component: Doc parser Version: 1.5
Keywords: Cc: Tom Trenka
Blocked By: Blocking:

Description

most methods on dojo.Deferred do not have any data in the API tool, e.g. Deferred.then

Change History (3)

comment:1 Changed 9 years ago by bill

I bet it's confused by the double assignments:

this.then = promise.then = function(/*Function?*/resolvedCallback, /*Function?*/errorCallback, /*Function?*/progressCallback){
			// summary
this.resolve = this.callback = function(value){
...

comment:2 Changed 9 years ago by bill

(In [23532]) fix typo, although I don't think this is the cause of the doc parser problem, refs #12151 !strict

comment:3 Changed 7 years ago by bill

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

This is working well now, with the new doc parser.

Note: See TracTickets for help on using tickets.