Opened 9 years ago

Closed 9 years ago

#12150 closed defect (wontfix)

[patch][CCLA] dojox.gfx: Text.setFont() throws an error when using gfx Canvas renderer

Reported by: Ed Chatelain Owned by: Eugene Lazutkin
Priority: high Milestone: 1.6
Component: DojoX GFX Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Reported by Patrick Ruzand (IBM)

When the canvas renderer is used, setting the font of a text shape throws a 'this._setFont is not a function' error.

To reproduce: launch the attached sample.

This private _setFont function is called by the public Shape.setFont() method default implementation and must be implemented by the renderer. While the svg, silverlight and vml renderer implement it, the implementation is missing in canvas.js.

Proposed fix: Since the current canvas renderer implementation does not render text (see the Text._renderShape impl. in dojox/gfx/canvas.js), the _setFont implementation must be an empty function.

Patch from Patrick (IBM, CCLA) and Ed (IBM, CCLA) to follow.

Attachments (2)

canvas_setFontBug.html (1.4 KB) - added by Ed Chatelain 9 years ago.
12150.patch (356 bytes) - added by Ed Chatelain 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Ed Chatelain

Attachment: canvas_setFontBug.html added

Changed 9 years ago by Ed Chatelain

Attachment: 12150.patch added

comment:1 Changed 9 years ago by Chris Mitchell

Summary: dojox.gfx: Text.setFont() throws an error when using gfx Canvas renderer[patch][CCLA] dojox.gfx: Text.setFont() throws an error when using gfx Canvas renderer

comment:2 Changed 9 years ago by Eugene Lazutkin

Milestone: tbd1.6
Resolution: wontfix
Status: newclosed

This ticket superseded by #12158.

Note: See TracTickets for help on using tickets.