Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12148 closed defect (duplicate)

[regression] DateTextBox and TimeTextBox creates additional popup wrapper div every time it's opened

Reported by: Kenneth G. Franqueiro Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.5
Keywords: datetextbox timetextbox popup Cc:
Blocked By: Blocking:

Description

This is easily reproducible in dijit/tests/form/test_DateTextBox.html and dijit/tests/form/test_TimeTextBox.html. Seems to be cross-browser; I tried IE8, FF 3.6, Chrome 10.

With firebug's HTML tab or webkit's element inspector open and the body tag expanded, click on any of the date/time text boxes to open its dropdown. Notice that a div is created for wrapping the popup. Now close the drop-down and reopen the same one again. Notice that *another* div, with the same id, is again created. This shouldn't be happening, and doesn't happen in 1.4.3.

The problem seems to be only with the wrapper div and not with the widget (which appears to get destroyed when the popup is closed in either version).

Unfortunately I'm unsure as to whether the problem is on the side of popup.js or _DateTimeTextBox.js. Both have changed between versions. This problem does not happen for !Menu or ComboBox/etc, though.

Change History (2)

comment:1 Changed 9 years ago by bill

Resolution: duplicate
Status: newclosed

Yup, see #11608.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.