Opened 8 years ago

Closed 8 years ago

#12131 closed defect (fixed)

[Patch][CLA] dijit.Dialog with no focusable elements does not get focus

Reported by: Jason Priestley Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Steps to reproduce:

open /dijit/tests/test_Dialog.html

click the "Show Unmoveable" button

Note that the dialog is not focused, and can not be dismissed using escape key.

I've attached a simple patch which makes the dialog focusable if no other elements can take focus. Work done on behalf of TeamPatent.

Attachments (1)

dialog_focus.diff (566 bytes) - added by Jason Priestley 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Jason Priestley

Attachment: dialog_focus.diff added

comment:1 Changed 8 years ago by bill

Milestone: tbd1.6
Owner: set to bill
Status: newassigned

comment:2 Changed 8 years ago by bill

I'll check in a fix to set focus to the close icon rather than the domNode, as per #8285.

comment:3 Changed 8 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [23488]) Make Dialog focus on close icon if the Dialog has no focusable elements. For TooltipDialog in this case, focus goes to the DOMNode, but officially TooltipDialogs must have at least one focusable element. Fixes #8285, #12131 !strict.

Also removed some FF workaround code about focusing an <input type=file>. It no longer seems to be needed (tested on FF3.6 on mac and windows). Refs #5934.

Finally, simplified Dialog aria tests.

Note: See TracTickets for help on using tickets.