Opened 9 years ago

Closed 8 years ago

#12130 closed defect (wontfix)

FF Crash on autosizing editor selection scrolling

Reported by: sfox Owned by:
Priority: high Milestone: future
Component: Editor Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

When using the editor (in dojo 1.5) with the auto-expanding option in Firefox you cannot select large sections of text (that would require scrolling to select). In FF 3.6 it crashes. In FF 4.0b8 it refuses to scroll.

To reproduce:

  1. In http://download.dojotoolkit.org/release-1.5.0/dojo-release-1.5.0/dijit/tests/editor/test_Editor.html

click the 'create expanding editor' button near bottom.

  1. Paste in large chunk of text (I just used lipsum) to this new editor div.
  1. Scroll down so that the beginning of the text is off-screen.
  1. Start selecting text and drag up to try to select the text that has scrolled off the top of the screen.

In FF 3.6.13 (on OS 10.6) you get a crash. On FF 4.0b8 and IE8 it simply refuses to scroll. This works fine on Safari 5.0.2 and Chrome 8.0.552.231: it scrolls and allows you to select all the text.

Change History (7)

comment:1 Changed 9 years ago by bill

Component: GeneralEditor
Owner: anonymous deleted

comment:2 Changed 9 years ago by Jared Jurkiewicz

I don't think this is an editor bug. This sounds like a Firefox bug. Editor doesn't control drag selection.

comment:3 Changed 9 years ago by bill

Certainly a browser crash is a browser bug, but it would be nice to workaround, especially since it will likely cause the user to lose a bunch of work. It would also be nice for the drag selection to work on other browsers (as this ticket description says other browsers don't crash, but they don't exactly work either).

One approach is to rearchitect auto-expand so that the editor's height is limited to the viewport size (or technically, the size of the closest ancestor node with scroll:auto/visible). If the content grows bigger than that, display a scroll bar. That would solve both the crash and the refusal-to-scroll, and it would also be less confusing for users, since (in the http://download.dojotoolkit.org/release-1.5.0/dojo-release-1.5.0/dijit/tests/editor/test_Editor.html example) the user can't tell that there's undisplayed editor content even when there is.

comment:4 Changed 9 years ago by sfox

Not that my opinion is the one that matters (though I do have several hundred users using the editor in auto-expand mode on a daily basis and features like this in the editor was a big reason I went with dojo rather than jquery+tinyMCE or the like), but switching to having a scroll-bar for autoexpand areas with large chunks of text would largely defeat the purpose in my use case.

The beauty of the autoexpand (when it works) is that users get the feel that they are just editing a page directly. If the information doesn't fit on the page then they use the normal browser scrollbar (which they are already used to using) and other familiar affordances for moving through the content rather than some additional scrollbar(s) which may or may not be present (on resizing?) within the page.

The current auto-expand behavior allows us to avoid having multiple, separately scrollable areas within an (already scrollable) browser window as we'd have with most of the other common contentEditable front-ends. The result is a much more natural feeling editing experience.

If this goes away in dojo I'll have to be looking at tinyMCE et al....

(and yes I realize that a bug report probably isn't the ideal place for this sort of feedback)

And if this is going to be left as something for FF folks to fix any pointers as to how I might best get this on their radar would be appreciated.

comment:5 Changed 9 years ago by bill

Yes, dual scrollbars can be confusing to users (although I also think the floating toolbar is confusing).

About reporting the FF bug, you could file a ticket at https://bugzilla.mozilla.org/ but I suspect they'd just mark it as already fixed in FF 4.0.

comment:6 Changed 8 years ago by Jared Jurkiewicz

Milestone: tbdfuture

comment:7 Changed 8 years ago by Jared Jurkiewicz

Resolution: wontfix
Status: newclosed

We can't really fix this. It's a browser native issue with its own scrolling code. I can suggest an easy alternative that gives you much the same look/feel. Use the FullScreen? plugin. It will make the editor take the entire browser viewport, making it look/work like a word processing program.

http://dojotoolkit.org/reference-guide/dijit/_editor/plugins/FullScreen.html#dijit-editor-plugins-fullscreen

Note: See TracTickets for help on using tickets.