Opened 9 years ago

Closed 6 years ago

#12123 closed enhancement (fixed)

Restore Updating Dojo Maven Repository

Reported by: Ming Zhe Huang Owned by: Greg Wilkins
Priority: high Milestone: 1.9
Component: General Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

The artifacts under Dojo Maven repository seem very old:
http://download.dojotoolkit.org/maven2
http://download.dojotoolkit.org/maven2-snapshot/
The latest build is 1.2.3.

Maven repository is very useful for project management and build. Would Dojo team consider to restore updating Maven repository? The standard build (standard profile) is sufficient.

Change History (6)

comment:1 Changed 9 years ago by bill

Owner: changed from anonymous to Greg Wilkins

comment:2 Changed 9 years ago by Ming Zhe Huang

The two links in the problem description are obsolete. The latest maven repositories are listed on http://download.dojotoolkit.org/

However, the artifacts in the snap-shot repository https://oss.sonatype.org/content/groups/dojo/ are old. Only part of them are snap-shots. Would Dojo team please consider providing the latest snap-shot, especially for the coming 1.6 release?

comment:3 Changed 6 years ago by dylan

Milestone: tbd1.9

Updates exist through 1.8.1.

gregw, can you update for 1.8.3 and 1.9.0b1?

comment:4 Changed 6 years ago by Kitson Kelly

#12574 is a duplicate of this ticket.

comment:5 Changed 6 years ago by Greg Wilkins

On it now.

Note that while I'm happy to continue to do this, it would be good to have another dojo committer share the knowledge so it can happen in my absence.

cheers

comment:6 Changed 6 years ago by Greg Wilkins

Resolution: fixed
Status: newclosed

Releases done for 1.8.3 1.8.4 and 1.9.0b2

Note: See TracTickets for help on using tickets.