Opened 9 years ago

Closed 8 years ago

#12112 closed defect (fixed)

[patch][cla][regression] dojox.form.manager._Mixin clobbers dijit._Widget "watch" function

Reported by: ben hockey Owned by: Eugene Lazutkin
Priority: high Milestone: 1.6
Component: DojoX Form Version: 1.5
Keywords: Cc: Kris Zyp
Blocked By: Blocking:

Description

in 1.6, dijit._Widget will introduce a watch function. the naming of this function causes an unfortunate clash with dojox.form.manager._Mixin which has a watch property.

to avoid this clash, i'm suggesting that dojox.form.manager._Mixin rename it's property. this change would not be backwards compatible but i would think that the name is not likely to be changed in dijit. any other options?

i think this change should be made before the release of 1.6 since the 2 classes are incompatible without this change. unless dijit changes the name of the property then it's inevitable that existing code using dojox.form.manager._Mixin will be broken in one way or another with the release of 1.6

Attachments (1)

12112-watching.diff (2.5 KB) - added by ben hockey 8 years ago.
proposed patch to change to watching

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by ben hockey

Owner: changed from dante to Eugene Lazutkin

comment:2 Changed 9 years ago by bill

Cc: Kris Zyp added
Summary: dojox.form.manager._Mixin clobbers dijit._Widget "watch" function[regression] dojox.form.manager._Mixin clobbers dijit._Widget "watch" function

Changed 8 years ago by ben hockey

Attachment: 12112-watching.diff added

proposed patch to change to watching

comment:3 Changed 8 years ago by ben hockey

Summary: [regression] dojox.form.manager._Mixin clobbers dijit._Widget "watch" function[patch][cla][regression] dojox.form.manager._Mixin clobbers dijit._Widget "watch" function

i'm proposing that dojox.form.manager.* changes to use watching.

i've attached a patch which would change watch to watching in dojox.form.manager.*

comment:4 Changed 8 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

(In [23700]) form manager: changed "watch" to "watching" to unclash with dijits, thx neonstalwart!, !strict, fixes #12112.

Note: See TracTickets for help on using tickets.