Opened 9 years ago

Closed 8 years ago

#12109 closed defect (fixed)

[regression] dijit.hasDefaultTabStop failure with editor iframe on WebKit

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Run dijit/tests/_base/tabindex.html on Chrome or Safari. There's 1 failure in the isTabNavigable function with hint editor_iframe. The problem is that a new child DIV with contentEditable=true has been added to Editor for the Webkit case. It'll be hard to always keep this function in sync with Editor. I think a feature-detection algorithm might be better. Please review the attached patch for a first draft at this.

Attachments (1)

12109.patch (1.5 KB) - added by Douglas Hays 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Douglas Hays

Attachment: 12109.patch added

comment:1 Changed 8 years ago by bill

Status: newassigned

That code is originally from #9766.

Your patch looks good except that we don't want dijit._base to depend on dojo.query(), since it's such a big chunk of code. I'll check in a modified version, slightly less robust but not using dojo.query().

comment:2 Changed 8 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [23450]) Fix dijit.hasDefaultTabStop() to detect that Editor on webkit is focusable. Editor on webkit has contentEditable on a <div> inside of <body> inside of the <iframe>. Fixes #12109.

Note: See TracTickets for help on using tickets.