Changes between Initial Version and Version 1 of Ticket #12104


Ignore:
Timestamp:
Dec 21, 2010, 11:05:58 PM (10 years ago)
Author:
bill
Comment:

I'm not sure if we even support loading from the file system anymore, but passing to James. I think this is an issue with the loader rather than with the parser.

Did this problem start showing up recently, after the AMD refactor? Does your code work correctly on the 1.5 release?

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #12104

    • Property Owner changed from bill to James Burke
    • Property Component changed from Parser to Core
  • Ticket #12104 – Description

    initial v1  
    22
    33Below is my deployed folder structure with DOjo framework
     4
     5{{{
    46C:\lib\DOJO\dojo
    57           \dijit
    68           \dojox
    79C:\test\1\pathtest.html  : where i have the sample html file
     10}}}
    811
    912I Just added a simple dijit text box to this html file. When i open this file in IE 8 it works good as expected. When i open this in FF.3.6.13 its showing error "Could not load 'dojo.parser'; last tried './parser.js'"  in FireBug COnsole.
    1013
    1114This is the way i referenced the Dojo library inside the html file
     15
     16{{{
    1217<script
    1318                        type="text/javascript"
     
    1621                        >
    1722</script>       
     23}}}
    1824
    1925This is the way i referenced the themes
     26
     27{{{
    2028<style type="text/css">
    21                         @import "../../lib/DOJO/dojo/resources/dojo.css";
    22                         @import "../../lib/DOJO/dijit/themes/tundra/tundra.css";
    23         </style>
     29        @import "../../lib/DOJO/dojo/resources/dojo.css";
     30        @import "../../lib/DOJO/dijit/themes/tundra/tundra.css";
     31</style>
     32}}}
    2433
    2534More over i alert the dojo.baseUrl before dojo.require("dojo.parser"); to know whats the base Url, in that case it alerts the base url as "../../lib/DOJO/dojo/' which is correct.
     
    2837Is there i need to do specific for firefox. I
    2938
    30 Dojo version : dojo_1_5_0_003
    31 Browser : FireFox.3.6.13, 3.5.x
     39Dojo version : dojo_1_5_0_003[[BR]]
     40Browser : !FireFox.3.6.13, 3.5.x