Opened 9 years ago

Closed 8 years ago

#12060 closed defect (fixed)

Accessibility Issue with EnhancedGrid

Reported by: rjgorthi Owned by: evan
Priority: high Milestone: 1.6
Component: Accessibility Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Am using Dojo 1.5 in my project and encountered a couple Accessibility issues:

Going by the Accessibility guidelines on http://docs.dojocampus.org/dojox/grid/DataGrid#accessibility-in-1-3-and-beyond:

To select a row, I need to: "With focus on a cell in a row, press the space bar."

The issue is, if I am in any of the cells other than the row Select Box, the row gets selected, on hitting Space. However, if I am in the cell that shows the "Select Box", and I hit on the Space bar, the row gets selected but it gets de-selected by itself in a second or two.

Also, what's the way to de-select a row? Show I hit on Space again? That doesn't seem to work.

Please let me know if any further information is required in this regard.

Thanks and Regards, ~Ramakrishna.

Change History (3)

comment:1 Changed 9 years ago by Adam Peller

Owner: changed from Becky Gibson to evan

comment:2 Changed 8 years ago by rjgorthi

One of the developers on our team investigated this issue further and found the following:

The defect exists because the _FocusManager which is used to set the focus when the keyboard keys are used was also selecting the cell by default. This was causing the row to be selected. Now when the code flow comes to the IndirectSelectionPlugin? the method sees that the checkbox is already selected and hence simply de-selects it.

Code changes: File Name: _FocusManager.js (single underscore) Method Name: _onContentKey: function(e, isBubble) Line Number: 809. Comment the line which is pasted below. g.selection.clickSelect(this.rowIndex, dojo.isCopyKey(e), e.shiftKey);

Please let me know if any further details are required in this regard.

Also let me know how and when can this be available to us in the form of an official fix.

comment:3 Changed 8 years ago by evan

Milestone: tbd1.6
Resolution: fixed
Status: newclosed

Fixed with [23789]

Note: See TracTickets for help on using tickets.