Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1206 closed defect (fixed)

DatePicker should NLS year

Reported by: bill Owned by: Adam Peller
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

For Japan, the year is typically printed as "2006 nen", in the same way that the month is printed as "8 gatsu" (with the kanji for those words). Currently it just shows up as "2006"

Attachments (2)

datepicker-nen.patch (1.0 KB) - added by Adam Peller 13 years ago.
Updated to new datetime.js method signatures (r5403)
Picture 1.png (18.1 KB) - added by Adam Peller 13 years ago.
What the DatePicker? widget looks like with the patch

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by dylan

Milestone: 0.4
Version: 0.40.3

comment:2 Changed 13 years ago by Adam Peller

Bill, I created a custom format for this and it works, however the formatting for the datepicker table is thrown off, so I won't check it in yet. Is this trivial to fix?

Do dates have to use the corresponding Japanese picturegram as well?

Changed 13 years ago by Adam Peller

Attachment: datepicker-nen.patch added

Updated to new datetime.js method signatures (r5403)

Changed 13 years ago by Adam Peller

Attachment: Picture 1.png added

What the DatePicker? widget looks like with the patch

comment:3 Changed 13 years ago by Adam Peller

The problem is on line 6 of DatePicker?.css:

.calendarBodyContainer {

width:160px;

change this to 100% and it works (but remove it and it doesn't -- I don't understand nested tables, apparently) However, the fixed width seems to have been deliberate as it makes the calendar slightly larger than normal. What was the intent and can we add the padding elsewhere?

comment:4 Changed 13 years ago by dylan

IIRC, the intent was the alignment of the up/down arrows, so that they appear in the same place, regardless of the width of the month.

comment:5 Changed 13 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [5887]) Fix CSS to allow for wider year strings, use localized years. Fixes #1206

comment:6 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.