Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11992 closed defect (worksforme)

FilteringSelect too tall in IE

Reported by: mark007 Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have a webpage with many FilteringSelects?. They show up perfectly in Chrome, Firefox, but not IE 8. This is with Dojo 1.5.0

In IE 8 their height is approximately double the height in the other browsers. I can use a css workaround to force it to be 17 pixels high which works until an item is selected from the FilteringSelect? which renders the arrow button invisible.

Simple testcase below. Nothing fancy just a simple FilteringSelect?

<html>
    <head>
        <link rel=stylesheet href="../../dojo/latest/dijit/themes/claro/claro.css" type="text/css">
        <link rel=stylesheet href="../../dojo/latest/dojo/resources/dojo.css" type="text/css">
    </head>

    <body class="claro">
                <select class="combo" dojoType="dijit.form.FilteringSelect">
                    <option>Hello</option>
                </select>

    </body>
    <script TYPE="text/javascript" src="../../dojo/latest/dojo/dojo.js" djConfig="parseOnLoad: true"></script>
    <script src="functions2.js"></script>
</html>

Attachments (1)

fs.html (596 bytes) - added by bill 9 years ago.
working test file, no height problem in IE8

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by bill

We'll try your test case, but note that FilteringSelect is showing up fine in our test case, test_FilteringSelect.html

comment:2 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed

The test case doesn't work because it doesn't require dijit.FilteringSelect or dojo.parser. Also, there's no function2.js in dojo, so that must be your own file. When I modify the test case to run on my machine, there's no height problem, either on dojo 1.5 or the latest code. I'll attach the test file.

Changed 9 years ago by bill

Attachment: fs.html added

working test file, no height problem in IE8

comment:3 Changed 9 years ago by mark007

I can reproduce on multiple machines bill. My testcase was incorrect in that functions2.js wasn't included. It does require FilteringSelect? and the parser.

http://trac.dojotoolkit.org/ticket/12096 seems to be a duplicate.

comment:4 Changed 9 years ago by bill

Are you saying that you can reproduce with the fs.html test case I attached? Or some other test case? If it's another test case, please attach it.

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.