Opened 8 years ago

Closed 8 years ago

#11987 closed defect (duplicate)

dojox.grid.DataGrid.doApplyCellEdit does not test if the value has changed

Reported by: goriol Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.5
Keywords: Cc: goriol@…
Blocked By: Blocking:

Description

dojox.grid.DataGrid?.doApplyCellEdit() doesn't test if the value has changed before calling this.store.setValue(...) and this.onApplyCellEdit(...).

I would all the more consider this a bug since store.isDirty() returns true after store.setValue() has been called with an unchanged value.

As a consequence, if we connect a function to save the store to the "onApplyCellEdit" notification, it will be triggered even if the user did not change the value.

Change History (2)

comment:1 Changed 8 years ago by bill

Owner: changed from bryanforbes to Bryan Forbes

comment:2 Changed 8 years ago by Bryan Forbes

Resolution: duplicate
Status: newclosed

This is a duplicate of #9579

Note: See TracTickets for help on using tickets.