Opened 9 years ago

Closed 9 years ago

#11984 closed defect (invalid)

Dialog: unable to access most recently created dialog when dialog created earlier is closed.

Reported by: ramyasethu Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

This is an issue where if a user takes an action two times that result in 2 dialogs popping up, for example, dialog1 pops up, then dialog2 pops up. If dialog1 is explicitly closed by the user, then user is unable to close or take any action of dialog2 (the most recent dialog).

Change History (5)

comment:1 Changed 9 years ago by bill

Component: GeneralDijit
Owner: anonymous deleted
Summary: Unable to access most recently created dialog when dialog created earlier is closed.Dialog: unable to access most recently created dialog when dialog created earlier is closed.

I don't see how a user could close dialog1 without closing dialog2 first. In any case, please attach a small test case and instructions to reproduce this problem.

comment:2 Changed 9 years ago by ramyasethu

The dialogs overlap when the second dialog pops up. The user can move the second dialog so the first dialog is visible and try to close the first dialog. The first dialog is unresponsive at this point but the user can close the second, more recent dialog and then close the first dialog. Is this the expected behavior of dialogs?

comment:3 Changed 9 years ago by bill

Yes, because dialogs are modal. Is that the only issue you are seeing?

comment:4 Changed 9 years ago by ramyasethu

Yes, please close this bug report.

comment:5 Changed 9 years ago by bill

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.