Opened 9 years ago

Closed 9 years ago

#11980 closed defect (fixed)

Safari 5 support and bug fixing for dojox.editor.plugins.LocalImage

Reported by: Gu Yi, He Owned by:
Priority: high Milestone: 1.6
Component: Editor Version: 1.5
Keywords: LocalImage safari bug Cc: drschwar@…
Blocked By: Blocking:

Description

This patch contains the following features for dojox.editor.plugins.LocalImage?.

  1. Added Safari 5 support. The "Open File" dialog of Safari 5 does not show modally, which needs to be handled.
  2. Fixed the UI problems. <hr/> will break the dialog in IE6. Use <div> instead. And included the CSS of file uploader in the plugin CSS so that user does not need to include it manually.
  3. Fixed the problem - the dropdown button of LocalImage? cannot be accessed by keyboard.

Change History (4)

comment:1 Changed 9 years ago by Adam Peller

It is usually best to handle unrelated items in separate tickets.

Including CSS of the file upload may make development easier, but it goes against our model. The CSS could easily become out of synch during development, and it may end up getting included twice.

comment:2 in reply to:  1 Changed 9 years ago by Gu Yi, He

Got it. I will extract the CSS of file uploader out of the LocalImage? CSS. And put it in the page that LocalImage? is deployed.

Replying to peller:

It is usually best to handle unrelated items in separate tickets.

Including CSS of the file upload may make development easier, but it goes against our model. The CSS could easily become out of synch during development, and it may end up getting included twice.

comment:3 Changed 9 years ago by Gu Yi, He

I keep the two CSS files separated. As a result, the testPluginsAll page might need to import /dojox/form/resources/FileUploader.css as well.

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [23348]) Fixes to browser specific bugs in LocalImage plugin:

  1. When the user clicks the Browse... button, the file dialog appears, but the TooltipDialog closes (FF/Chrome/Safari < 5)
  1. the user can do nothing to the file dialog until he clicks on the page once, which closes the TooltipDialog (issue #2, Safari 5)

Both bugs are caused by browser problems with the system's file select dialog.

Patch from Gu Yi (IBM, CCLA), thanks!

Fixes #11980 !strict.

Note: See TracTickets for help on using tickets.