Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#11951 closed defect (fixed)

dojo.dnd.autoScrollNodes ignoring overflow-y: scroll

Reported by: JMace Owned by: Eugene Lazutkin
Priority: high Milestone: 1.7
Component: DnD Version: 1.5
Keywords: dojo dnd autoscrollnodes overflow getcomputedstyle overflow-y Cc:
Blocked By: Blocking:

Description

Apologies if this has been raised elsewhere.

I have a dojo dnd Source inside a scrolling div. When I drag a dnd item and attempt to have the div scroll automatically by dragging to the top or bottom of the scrollable div, it doesn't do anything. The overflow-y property is set to scroll. When I change the property to auto, it functions correctly.

I am using 1.3 but have tested on 1.5 and it appears not to be working there either.

I've knocked up some html to demonstrate it. By changing the overflow-y property between scroll and auto, you can see the problem.

I checked the source and it appears that the problem is in dojo.dnd.autoscroll.js on line 64. There is a call

var s = dojo.getComputedStyle(n);

then on the following line, a check for s.overflow. s.overflow should be scroll, but it's null, and so the div is being ignored.

Attachments (1)

text.html (2.2 KB) - added by JMace 9 years ago.
HTML to reproduce error

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by JMace

Attachment: text.html added

HTML to reproduce error

comment:1 Changed 9 years ago by bill

Component: GeneralDnD
Owner: changed from anonymous to Eugene Lazutkin

comment:2 Changed 9 years ago by Eugene Lazutkin

Milestone: tbd1.6
Status: newassigned

comment:3 Changed 8 years ago by bill

Milestone: 1.61.7

comment:4 Changed 8 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [24995]) dnd: made auto-scroll aware of overflow-x and overflow-y settings, thx JMace!, !strict, fixes #11951.

comment:5 Changed 7 years ago by wa1one

There is an error in IE 9 when item dragged the scrollTop is set to zero.

comment:6 Changed 7 years ago by bill

wa1one - comments in closed tickets are generally ignored. If you want someone to look at the problem you'll need to open a new ticket with a test case and more specific instructions to reproduce the error.

Note: See TracTickets for help on using tickets.