Opened 9 years ago

Closed 9 years ago

#11948 closed defect (fixed)

[regression] 100%x100% BorderContainer in Claro has scrollbars

Reported by: Adam Peller Owned by:
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: Cc: santilli@…
Blocked By: Blocking:

Description

The 1px border introduced in Claro causes scrollbars for he one extra pixel when the BorderContainer? is set to take over the entire window.

Change History (7)

comment:1 Changed 9 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [23180]) Introduce override for border:0 on 100%x100% BorderContainers?. Had to use \!important hack. Fixes #11948

comment:2 Changed 9 years ago by bill

Milestone: tbd1.6
Resolution: fixed
Status: closedreopened

Unfortunately, the child selector BODY > .dijitBorderContainer won't work on IE6, so this solution won't work. It will presumably remove all borders on IE6, making the behavior inconsistent with other browsers.

Also, all claro rules need to have .claro in the selector, and !important isn't needed. Probably you thought you needed !important because you forgot .claro.

comment:3 Changed 9 years ago by Katie Vance

[23180] causes a test failure in BorderContainer_full. Be sure to run the automated tests before fixing this issue.

comment:4 Changed 9 years ago by Julie Santilli

The link provided - indicates page can not be found. Is there another file to review and reproduce and/or send screen shot of error occurring in IE6. We are also looking into it.

comment:5 Changed 9 years ago by Adam Peller

(In [23195]) rollback [23180] and remove overflow:hidden from BorderContainer_full tests. Refs #11948

comment:6 Changed 9 years ago by Adam Peller

(In [23201]) rollback test change from [23180] to dubious but long-standing setting of overflow: hidden, masking error refs #11948

comment:7 Changed 9 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [23284]) Remove border on BorderContainer. It's undesirable on both full viewport BorderContainers and on BorderContainers nested inside of other BorderContainers. Apps can specify a border explicitly if they want one.

Also removed padding (a.k.a "outer gutters") on BorderContainers nested inside of other BorderContainers since the nesting of BorderContainers should be transparent to a user. See dijit/tests/layout/test_Gui.html for testing, although it doesn't look very good in claro since claro doesn't support tabstrip for TabContainers.

Fixes #11948.

Note: See TracTickets for help on using tickets.