Opened 10 years ago

Closed 10 years ago

#11930 closed defect (worksforme)

EnhancedGrid - IndirectionSelection plugin has problems when data changes.

Reported by: Dave Thompson Owned by: evan
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

When the datastore is changed or when new items are added or removed, the IndirectSelection? checkboxes disappear. It looks like this behavior is being caused by caching the checkbox widgets in the 'widgetMap' property of the IndirectSelection? cell.

Change History (5)

comment:1 Changed 10 years ago by Adam Peller

Component: GeneralDojoX Grid
Owner: changed from anonymous to evan

comment:2 Changed 10 years ago by bill

Owner: changed from evan to Evan

comment:3 Changed 10 years ago by bill

Owner: changed from Evan to evan

comment:4 Changed 10 years ago by evan

Not reproduced in trunk for 1.6, this issue no longer exits once #11645 done.

Need to close this.

comment:5 Changed 10 years ago by Adam Peller

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.