Opened 9 years ago

Closed 9 years ago

#11901 closed defect (worksforme)

Dialogs and tooltips not rendering over browser plugins (e.g ActiveX control)

Reported by: Earl Hood Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5
Keywords: Cc: Katie Vance
Blocked By: Blocking:

Description

It looks like the work for #9805 does not handle IE (7 & 8) properly. Dialogs and tooltips will not render over an ActiveX control in IE.

Using the debugging tools provided with IE8, it appears that the BackgroundIFrame created does not have the expected height value, even thought the height CSS setting is set to 100%. The actual height is much less, causing only the top part of a dialog or tooltip to render over the ActiveX control.

To correct the problem, I modified code so that the bgiframe created will have the height set to an appropriate pixel value so the dialog/tooltip will render over the ActiveX control.

The size of the modifications is minor. Diff of changes based on subversion source is attached.

Attachments (3)

dijit-bgiframe-ie-fix.patch (1.2 KB) - added by Earl Hood 9 years ago.
Patch to dijit source DialogUnderlay?.js and Tooltip.js
edit-dialog-obscured-by-activex.jpg (60.6 KB) - added by Earl Hood 9 years ago.
Screen shot of a dialog partially obscured by activex control
tooltip-obscured-by-activex.jpg (96.9 KB) - added by Earl Hood 9 years ago.
Screen shot of a toolip partially obscured by activex control

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Earl Hood

Attachment: dijit-bgiframe-ie-fix.patch added

Patch to dijit source DialogUnderlay?.js and Tooltip.js

comment:1 Changed 9 years ago by bill

Cc: Katie Vance added

test_bgIframe.html looks like it's working to me on IE8. Can you attach a test case where this fails?

Changed 9 years ago by Earl Hood

Screen shot of a dialog partially obscured by activex control

Changed 9 years ago by Earl Hood

Screen shot of a toolip partially obscured by activex control

comment:2 Changed 9 years ago by Earl Hood

I added two screen shots using IE7 showing how a dialog and a tooltip are being obscured by the ActiveX control.

The ActiveX control is a CGM viewer. Since it is a licensed product, the control cannot be provided to others w/o a license.

Note, the application does have multiple panes for viewing content. One pane contains a TOC (via digit's Tree), one has textual-based content, and the other is the pane that contains the graphic/ActiveX control.

The application has nested containers and content panes, so it is possible that plays a role in the behavioral problem being seen. IE may not provide proper rendering of 100% height due to the complexity of DOM.

comment:3 Changed 9 years ago by bill

You'll need to attach some sort of test case (not necessarily using that control), I can't checkin a patch w/out a reproducible test case.

comment:4 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed

Closing for lack of test case.

I did however recently modify the !BackgroundIFrame to do explicit sizing whenever IE is in quirks mode, maybe that fixes the problem.

Note: See TracTickets for help on using tickets.