Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1190 closed defect (fixed)

[patch][cla] ComboBox Extra Spacing/Strange Gaps/Unusual Style

Reported by: rheaghen@… Owned by: itorrey
Priority: high Milestone:
Component: design/interactions Version: 0.3
Keywords: combobox style Cc:
Blocked By: Blocking:

Description

the combobox's style is kindof strange. I'm not sure why its layout was designed th way it was, buy I've created a look more typical to other dropdowns

it includes a style and an image

src/widget/templates/HtmlComboBox.css

input.dojoComboBoxInput {
	/* font-size: 0.8em; */
	border: 0px;
}

.dojoComboBoxOptions {
	font-family: Verdana, Helvetica, Garamond, sans-serif;
	/* font-size: 0.7em; */
	background-color: white;
	border: 1px solid #afafaf;
	position: absolute;
	z-index: 1000; 
	overflow: auto;
	-moz-opacity: 0;
	cursor: default;
}

table.dojoComboBox {	
	border: 1px solid #afafaf;
	border-collapse: collapse;
}

table.dojoComboBox img{
	vertical-align:bottom;
}

.dojoComboBoxItem {
	padding-left: 0px;
	padding-top: 0px;
	margin: 0px;
}

.dojoComboBoxItemEven {
	background-color: #f4f4f4;
}

.dojoComboBoxItemOdd {
	background-color: white;
}

.dojoComboBoxItemHighlight {
	background-color: #63709A;
	color: white;
}

also, I changed the dimentions of the button graphic to 15px/20px (src/widget/templates/images/combo_box_arrow.png)

now your combobox won't get picked on by the other select boxes for looking different.

Attachments (1)

combo_box_arrow.png (307 bytes) - added by rheaghen@… 13 years ago.
new button graphic - combobox

Download all attachments as: .zip

Change History (11)

comment:1 Changed 13 years ago by bill

Owner: changed from anonymous to itorrey
Summary: FIXED - ComboBox Extra Spacing/Strange Gaps/Unusual Style[patch] ComboBox Extra Spacing/Strange Gaps/Unusual Style

rheaghen - we need you to sign a CLA before accepting patches.

In any case, Torrey is designing the theme for our UI so it's up to him what it looks like.

comment:2 Changed 13 years ago by rheaghen

Version: 0.20.3

Whoa''' this is the first time this has ever happened. I've never been an active contributor of any project before, as this is only my third year as a developer. I would be happy to comply with your requests. could you please provide more specifics? Do you have access to my email? Should I just be logging in as guest?

What is a CLA?

From Wikipedia, the free encyclopedia

Jump to: navigation, search

CLA is a three-letter abbreviation that may mean:

    * California Library Association
    * Canadian Library Association
    * Command Line Arguments
    * Conjugated linoleic acid
    * Cuban Liberator Army
    * Child Language Aquisition
    * Computer Law Association <--- maybe?
    * Country Land and Business Association...
           ...(formerly the Country Landowners' Association)

Torrey, please feel free to contact me throgh my gmail account. The same name listed below will work just fine. sorry for the anti-robot tactics with the email.

-Rheaghen

Changed 13 years ago by rheaghen@…

Attachment: combo_box_arrow.png added

new button graphic - combobox

comment:4 Changed 13 years ago by rheaghen@…

Component: GeneralWidgets
Keywords: combobox style added
Milestone: 0.3.1
Summary: [patch] ComboBox Extra Spacing/Strange Gaps/Unusual StyleComboBox Extra Spacing/Strange Gaps/Unusual Style

Ok... I'll fax in the icla tomorrow morning. note: added the button graphic to illustrate the need for a different shaped button. if you'd lik eit to match the old design, I'd be happy to make that happen.

comment:5 Changed 13 years ago by rheaghen@…

Ok... my CLA has been faxed. =)

comment:6 Changed 13 years ago by dylan

Milestone: 0.3.10.4

comment:7 Changed 13 years ago by dylan

Summary: ComboBox Extra Spacing/Strange Gaps/Unusual Style[patch][cla] ComboBox Extra Spacing/Strange Gaps/Unusual Style

comment:8 Changed 13 years ago by dylan

Component: Widgetsdesign/interactions
Type: enhancementdefect

not really an enhancement, so changing status so that it can still make it into 0.4

comment:9 Changed 13 years ago by itorrey

Resolution: fixed
Status: newclosed

Updates made recently seem to fix this issue. For the moment we will keep the current graphic for the arrow but I'll save this one as I really like it and it could become part of a new theme we do for 0.5

comment:10 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.