Opened 9 years ago

Closed 9 years ago

#11859 closed defect (fixed)

Tooltip placement problem in IE6

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: Cc: haysmark, Katie Vance
Blocked By: Blocking:

Description

Load test_Tooltip_placement.html with IE6 and resize the window width to 700px. Click in the 3rd textbox from the top and you'll see that the tooltip overlaps the textbox even though there's plenty of room for the tooltip to move to the left. The problem seems to be this rule in ALL the themes:

.dj_ie6 .claro .dijitTooltipLeft {
        padding-left: 15px;
}

Unfortunately I don't know if that rule fixes some other problem.
This problem is causing failures with robot/Tooltip_placement.html.

Change History (5)

comment:1 Changed 9 years ago by Douglas Hays

Cc: haysmark added

comment:2 Changed 9 years ago by bill

Cc: Katie Vance added

That's odd, the code you quoted is actually there to prevent an overlap problem. I tried removing that code a few weekse ago and reproduced the overlap problem, but now I can't reproduce it, neither on trunk/ nor on the 1.5/ branch. The overlap problem wasn't related to the test_Tooltip_placement.html corner case testing of aroundNodes that almost fill up the viewport (horizontally).

Katie, can you reproduce the problem when that IE6 CSS isn't there, either on trunk or the 1.5/ branch? And also, if it turns out that CSS isn't needed then that code in Tooltip.orient() can be simplified.

comment:3 Changed 9 years ago by Katie Vance

I do see the issue in the trunk. I'm not sure why we would test this on 1.5 because the new tooltip placement code was not backported to 1.5 and therefore the tests would be expected to fail on 1.5 anyway.

In the trunk, if we remove the padding left, it does not fix the issue, it just masks it in most cases (making it look like there isn't extra whitespace for the tooltip). If we continue to make the browser smaller after removing the css, the tests will eventually fail, because the tooltip will eventually overlap the textbox. The issue is that clicking on the text box will scroll the window to show the whole textbox leaving less whitespace for the tooltip. Then the space left for the tooltip is too small for the contents and therefore is placed on top of the textbox. When this happens in the other browsers, the tooltip is cutoff rather than placed on top of the textbox.

comment:4 Changed 9 years ago by bill

I'm not too worried about what happens when the available space is so small that a single word overflows it.

I guess since neither Katie nor Doug can figure out why that IE hack code is needed that I'll remove it.

comment:5 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [23066]) Removing apparently vestigal code for IE6, fixes #11859 !strict. Note though that the test_Tooltip_placement.html test file has changed so the steps specified in the ticket no longer apply; the browser window needs to be wider to leave space for the tooltip to appear without overlapping.

Note: See TracTickets for help on using tickets.