Opened 9 years ago

Closed 3 years ago

#11858 closed defect (invalid)

IE9: viewport dimensions incorrect with larger font DPI

Reported by: Darreny Owned by:
Priority: high Milestone: 1.11
Component: General Version: 1.5
Keywords: IE9 DPI viewport getviewport Cc:
Blocked By: Blocking:

Description

The problem described below occurs when the font DPI in Windows is set larger than the standard DPI. It has been tested on Windows 7 Professional 64-bit, 1920x1080 resolution, and with font DPI = 125% and 150%. This problem DOES NOT occur in Google Chrome v6.0.472.63, Firefox v3.6.10, and Safari 5.0.2.

In IE9 beta with "X-UA compatible" set to IE7 or IE8, dijit.getViewport() and dojo.window.getBox() (found in dijit.Dialog) returns incorrect width and height dimensions. The dimensions are larger than the browser's viewport because the horizontal and vertical scroll bars appear.

Without setting "X-UA compatible" (falling back to IE9 standards), dijit.Dialog fails, but dijit.getViewport() and dojo.window.getBox() return CORRECT dimensions. The pop-up dialog box has opacity=0, which leads me to believe that dojo is trying to do a fade that is not supported by IE9. The dialog box never appears rendering the page useless because the underlay "locks" the screen.

The attached example shows the uses of dijit.getViewport() and dijit.Dialog in the form of buttons, a "Viewport" button and a "Pop-up" button, respectively. The former simply sets the style of a <div> to the viewport dimensions returned by dijit.getViewport(). The latter creates a basic Dijit dialog. As you can see by clicking on either button, the horizontal and vertical scroll bars appear, and then disappear when you click on the "Viewport" button again or close the pop-up.

Attachments (1)

DojoViewportAndPopupTest.html (1.9 KB) - added by Darreny 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Darreny

comment:1 Changed 9 years ago by Darreny

Digging deeper, this is actually an IE9 bug. I was able to reproduce this without using Dojo. I will file it with Microsoft.

This bug can probably be closed

comment:2 Changed 9 years ago by Eugene Lazutkin

Please include a reference to a filed bug (with MS), if it is possible, and keep us posted. It is better to close this ticket when it is fixed (or declined) so people are aware of the problem.

comment:3 Changed 8 years ago by Kenneth G. Franqueiro

FWIW, I can only reproduce this problem in IE7 or Quirks modes. IE8 and IE9 modes seem fine. (tested running IE9 in Win7 at 120dpi, a.k.a. 125%)

Also, the dialog-locking-up problem has already been fixed in 1.6.

Do we know if this is still an IE-side problem and the status of it if so?

comment:4 Changed 8 years ago by Chris Mitchell

Owner: anonymous deleted

comment:5 Changed 3 years ago by dylan

Milestone: tbd1.11
Resolution: invalid
Status: newclosed

Given the lack of response, I'm closing this out.

Note: See TracTickets for help on using tickets.