Opened 13 years ago

Closed 13 years ago

#1185 closed enhancement (worksforme)

Widget creation - linked to constructor's namespace

Reported by: andrei.neculau@… Owned by: bill
Priority: low Milestone: 1.0
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

When replicating a Dojo widget, the new Widget may still have some lines that create sub-widgets, like for instance FloatingPane? creates a ResizeHandle?.

But when creating a new FloatingPane? in a different namespace, it still creates a ResizeHandle? from the Dojo namespace.

There should be some widget property that states the type of the sub-widgets. Something like: subwidgets: {resize: "dojo:ResizeHandle", ...}, so that in the code there will be dojo.widget.createWidget(this.subwidgets.resize, ...);

Change History (3)

comment:1 Changed 13 years ago by bill

Milestone: 0.40.6

If you want floating pane to use another widget rather than resize handle, you can subclass floating pane and change the behavior. Not sure what the issue is. It's inconvenient because it's hard to override just that one part?

comment:2 Changed 13 years ago by bill

Priority: highlow

comment:3 Changed 13 years ago by bill

Resolution: worksforme
Status: newclosed

We've gotten rid of namespaces in 0.9 altogether; no longer an issue.

Note: See TracTickets for help on using tickets.