Opened 9 years ago

Closed 9 years ago

#11843 closed defect (fixed)

Using FF 3:6.10 I don't get the tooltips on charts

Reported by: zladivliba Owned by: Eugene Lazutkin
Priority: high Milestone: 1.6
Component: Charting Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I just noticed after upgrading firefox that I don't get tooltips over charts using my new version : 3.6.10 under ubuntu.

Nothing appears.

Change History (8)

comment:1 Changed 9 years ago by Eugene Lazutkin

Milestone: tbdfuture
Priority: highestnormal
severity: blockernormal
Status: newassigned

Do bundled tests work for you? Is there any way to reproduce the effect with a minimalistic example?

comment:2 Changed 9 years ago by zladivliba

I'm looking at this page: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/charting/tests/test_event2d.html

And I can't get any tooltips. By the way I'm on irc on the dojo channel logged right now, if you need more info, don't hesitate to contact me.

comment:3 Changed 9 years ago by zladivliba

I've tried this code but I'm not sure it's set up properly to see the tooltip

console.log("building tasksCOmpleted");

this.areaChart = new dojox.charting.Chart2D(this.TasksCompletedGraph?); this.areaChart.addAxis("x"); this.areaChart.addPlot("default", {type: "StackedAreas?"}); this.areaChart.addSeries("Series D", [5,10,14,12,18,17,11]); this.areaChart.addSeries("Series A", [3,5,4,2,8,7,1]);

var anim10c = new dojox.charting.action2d.Tooltip(this.areaChart, "default");

this.areaChart.render();

comment:4 in reply to:  2 Changed 9 years ago by Eugene Lazutkin

Replying to zladivliba:

I'm looking at this page: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/charting/tests/test_event2d.html

And I can't get any tooltips. By the way I'm on irc on the dojo channel logged right now, if you need more info, don't hesitate to contact me.

I don't see any tooltips either with FF 3.6.12pre. Probably something has changed in dijit.Tooltip. I'll investigate.

comment:5 Changed 9 years ago by zladivliba

Ok, I just cheched the code I provided doesn't work at all ; my fault I cc somehting that has nothing to do with the current question ;-)

But still there's a problem with the tooltips because of the page I pointed out I thnik.

comment:6 Changed 9 years ago by gary.bishop.unc

Chart tooltips do not work on Chrome 8.0.552.215 nor on Firefox 3.6.13 running on Ubuntu 10.10.

comment:7 Changed 9 years ago by Eugene Lazutkin

Milestone: future1.6

comment:8 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [23512]) Charting: abbreviated labels, thx Xiang Zhou (CCLA, IBM)!, !strict, fixes #11631, fixes #11843.

Note: See TracTickets for help on using tickets.