Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11832 closed defect (fixed)

Remove isOpera from dojo.byId IE code path

Reported by: miketaylr Owned by: anonymous
Priority: high Milestone: 1.6
Component: General Version: 1.5
Keywords: Cc: dante
Blocked By: Blocking:

Description

There's a check for isOpera before d.byId is defined:

if(dojo.isIE || dojo.isOpera){

I wasn't around, but I'm guessing this was added because of an old bug where Opera mimicked IE in that it would return @name or @id. This was fixed in Opera core in March of 2007--which was around Opera 8.5. You can test Opera 9+ here to see that gEbId works now: http://jsbin.com/edava4/

Since Dojo core only officially supports Opera 9+, I suggest removing the isOpera condition. Then you can claim all kinds of perf increases and make some sweet bar charts for your blog.

Looking at our numbers, roughly .1% of Opera Desktop users are using Opera <= 8.5.

Change History (3)

comment:1 Changed 9 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [22972]) Fixes #11831 and #11832. Make sure byId consistently returns null, and use the standards path for Opera, confirmed that it works for what we support by an Opera person, and the change does not affect Core test results. \!strict

comment:2 Changed 9 years ago by James Burke

Milestone: tbd1.6

comment:3 Changed 9 years ago by James Burke

Thanks for the detailed run-down, miketaylr!

Note: See TracTickets for help on using tickets.