Opened 9 years ago

Closed 7 years ago

#11824 closed defect (wontfix)

dojo.charting not working with FF 3.5.3 for Ubuntu

Reported by: zladivliba Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: Charting Version: 1.5
Keywords: charting, ff, firefox Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

I've had a LOT of problems using FF under linux with dojo.charting. Usually the bugs are that nothing is shown inside a graphic. I'm parsing this piece of code :

dojo.require("dojox.charting.Chart2D");

makeCharts = function(){

        var chart1 = new dojox.charting.Chart2D("simplechart");
        chart1.addPlot("default", {type: "Lines"});
        chart1.addAxis("x");
        chart1.addAxis("y", {vertical: true});
        chart1.addSeries("Series 1", [1, 2, 2, 3, 4, 5, 5, 7]);
        chart1.render();
       
};

dojo.addOnLoad(makeCharts);

and nothing appears inside the graph (I see the axes though). I've tested the same thing under chrome and it works.

It seems also that using an array makes the navigator bug (I never get to see the array of elements inside a graph, only the first elements).

Attachments (1)

test.htm (5.5 KB) - added by rsands 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by zladivliba

More details about my navigator : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Ubuntu/9.10 (karmic) Firefox/3.5.3

comment:2 Changed 9 years ago by Eugene Lazutkin

Milestone: tbdfuture
Priority: highestnormal
severity: blockernormal
Status: newassigned

FF 3.5.3 for Ubuntu --- this is what I use for testing and development on daily basis. Could you provide a test file, which is broken for you?

comment:3 Changed 9 years ago by Eugene Lazutkin

Description: modified (diff)

...or if some tests/demos do not work for you on this browser, just give me their links.

comment:4 Changed 9 years ago by zladivliba

What else can I say : I didn't see any lines inside the graph. Just both axis but nothing inside it.

I tested on chrome and I saw the line inside the graph. I don't see what more can I say about it.

If you can't reproduce well there's a problem, maybe it's my navigator (i've updated since) but seems weird.

comment:6 Changed 9 years ago by sylence

I can confirm that problem on Firefox 3.5.13 with all extensions disabled. The second example on the documentation doesn't work (the simple one in the "Usage" chapter).

http://dojotoolkit.org/reference-guide/dojox/charting.html#dojox-charting

comment:7 in reply to:  6 Changed 9 years ago by Eugene Lazutkin

Replying to sylence:

I can confirm that problem on Firefox 3.5.13 with all extensions disabled. The second example on the documentation doesn't work (the simple one in the "Usage" chapter).

http://dojotoolkit.org/reference-guide/dojox/charting.html#dojox-charting

I just tried it with Firefox 3.6.12pre and it works for me. Probably I need to find 3.5 and try it...

comment:8 Changed 9 years ago by sylence

I've switched to Firefox 3.6 and now it really works. But FF3.5 users will still not be able to see these simple charts (while complex one still work there).

Changed 8 years ago by rsands

Attachment: test.htm added

comment:9 Changed 8 years ago by rsands

I've added a simple test file, test.htm, which is based on the example mentioned above. Also in the file, I've overridden the function dojox.charting.plot2d.common.collectSimpleStats so that more logging is available. With Firebug enabled, logging such as this will occur:

stats.hmin prior = Infinity
stats.hmin after = 1
stats.hmin prior = Infinity
stats.hmin after = 2

This test file fails to produce graph lines for me on Firefox 3.5.16 and Windows 7. I've found two remedies for this:

  1. Force the min value for the x-axis to be 1 - change this line
chart1.addAxis("x");

to

chart1.addAxis("x", {min: 1});
  1. Revert dojo.delegate to dojo.clone (as it is in Dojo 1.4) - change this line
var stats = dojo.delegate(dojox.charting.plot2d.common.defaultStats);

to

var stats = dojo.clone(dojox.charting.plot2d.common.defaultStats);

It seems based on the logging that I've added that Firefox 3.5 has a problem with the delegated "stats" var. It appropriately reads the value Infinity from stats.hmin during the first loop iteration and sets stats.hmin to 1. However, during the second iteration, it's back to Infinity! I don't think that this is a problem with dojo.delegate. It instead seems to be a problem with Firefox caching the value Infinity from the delegated value.

comment:10 Changed 7 years ago by cjolif

Resolution: wontfix
Status: assignedclosed

Firefox 3.5 is not supported anymore in recent Dojo releases nor by Mozilla. I think we should close that one for now except if somebody comes up with a patch for old releases.

Note: See TracTickets for help on using tickets.