Opened 9 years ago

Closed 7 years ago

Last modified 5 years ago

#11822 closed defect (fixed)

BackgroundIFrame: applet over underlay

Reported by: paccoo Owned by: bill
Priority: high Milestone: 1.9
Component: Dijit Version: 1.5
Keywords: underlay applet FF Cc: Katie Vance
Blocked By: Blocking:

Description (last modified by bill)

The underlay of dijit.Dialog and dijit.DateTextBox is not working proper with java applets on the FF, Chrome and Opera browsers. The applet component is over the underlay. I think that the problem is in the dijit.BackgroundIframe component and has something to do with the opacity of the underlaywrapper stylesheets. Also there is another point with the dijit.MenuItems on the opera browsers, even the menu items are under the applet on Opera.

To reproduce this defect pls check the test_bgIframe.html.

My OS : Windows 7 x64

Attachments (2)

dialog.jpg (99.7 KB) - added by paccoo 9 years ago.
Screenshot of dialog
dateTextBox.png (42.3 KB) - added by paccoo 9 years ago.
Screenshot of DateTextBox? - strange thing is you can only see the highlighted "today"

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by paccoo

By the way...

Chrome v. = 6.0.472.63
FF v. = 3.6.10
Opera v. = 10.62

comment:2 Changed 9 years ago by bill

Description: modified (diff)
Summary: Background IFrameBackgroundIFrame: applet over underlay

#9805 fixed a related issue.

I tried test_bgIframe.html on FF3.6/Win7, it looks like it's working OK to me. Showing the dialog grays out the whole screen, including the area where the background iframe is.

Can you attach a screenshot?

Changed 9 years ago by paccoo

Attachment: dialog.jpg added

Screenshot of dialog

Changed 9 years ago by paccoo

Attachment: dateTextBox.png added

Screenshot of DateTextBox? - strange thing is you can only see the highlighted "today"

comment:3 Changed 9 years ago by Katie Vance

Cc: Katie Vance added
Owner: set to bill

Tooltips have the same issue. Also, I am unable to load the test on Oracle using the trunk.

comment:4 in reply to:  3 Changed 9 years ago by Katie Vance

Replying to ksv:

Tooltips have the same issue. Also, I am unable to load the test on Opera using the trunk.

comment:5 Changed 9 years ago by Katie Vance

The Opera bug was fixed by [23117]

comment:6 Changed 9 years ago by bill

OK, so it's not just that "The applet component is over the underlay." but that the applet is over the popup Dialog/tooltip.

It's a bug with sun's java VM and I'm not sure how to workaround it, short of dojo.query("applet").style("visibility", "hidden")

I found http://stackoverflow.com/questions/1230546/javascript-drop-down-menu-and-flash-conflict but that's about flash. And http://bugs.sun.com/bugdatabase/view_bug.do;jsessionid=350dd0219304a1ffffffff970a83b528b2e86?bug_id=6646289 indicates that there's no workaround for this.

comment:7 Changed 9 years ago by Katie Vance

The test will also fail on IE6 if you open the calendar drop down before opening the dialog box. After opening the menu first, the dialog box will then show behind either an applet or pdf.

comment:8 Changed 9 years ago by Katie Vance

test_bgIframe.html has be automated as robot/BgIframe.html. The test is set to only run for IE7 and newer. Once this defect is fixed, then we need to remove the if statement in general-module.

comment:9 Changed 9 years ago by bill

(In [23177]) Fix bug where this.iframe was being referenced in resize() before being set, causing sizing problems on IE. Fixes #11944, refs #11822 (although that ticket is really about FF and webkit). !strict.

comment:10 Changed 9 years ago by bill

Milestone: future

From my reading it looks like this is a problem specific to applets ignoring z-index, and I'm not sure how to fix it. It needs a fix from the java VM itself.

comment:11 Changed 7 years ago by bill

Milestone: future1.9

OK, using the iframe on chrome now works for applets, although it doesn't work for flash, at least in my tests on a Windows XP VM.

On FF the Dialog and DateTextBox are showing fine nowadays, even without any changes to the dojo code. (I.e. I can see them in test_bgIframe.html even on Dojo 1.7.)

comment:12 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29907]:

Turn on BackgroundIframe for chrome too, to help with applets. Also add has() flag to control whether or not BackgroundIframe shows. Starting in 2.0 I'd like it to be false by default.

Fixes #11822, #16268 !strict.

comment:13 Changed 6 years ago by bill

In [30323]:

Backport of has("bgIframe") flag to 1.8 branch. Didn't change the default conditions when it's true though, so if you want to get the background iframe on Chrome then you need to manually set it, like test_bgIframe.html does. Refs #11822, #16268 !strict.

comment:14 Changed 6 years ago by bill

In [30324]:

Backport of has("bgIframe") flag to 1.7 branch. Didn't change the default conditions when it's true though, so if you want to get the

background iframe on Chrome then you need to manually set it, like test_bgIframe.html does. Refs #11822, #16268 !strict.

comment:15 Changed 5 years ago by bill

Note that the background iframe is no longer needed on the latest versions of Chrome and FF. Still needed on IE8-IE10 though. Not sure about IE11.

comment:16 Changed 5 years ago by Adrian Vasiliu

According to my tests in a limited scope (dojox/mobile/ComboBox), it is still needed for IE 10.0.9200.16798 on Win 7, but it is not needed for both IE 10.0.9200.16843 on Win 8 and IE 11 on Win 8.1.

comment:17 Changed 5 years ago by Bill Keese <bill@…>

In fb0203a01d0869ad5278c5675d986698209a7c24/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.