Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11816 closed defect (fixed)

Nested tab container and title pane bug

Reported by: Katie Vance Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Steps to reproduce:

  1. Load dijit/tests/layout/test_TabContainerTitlePane.html
  2. that Tab 3 and Tab 4 (nested inside the titlepane) are rendering content.
  3. Minimize the title pane
  4. Click on Tab 2
  5. Click back on Tab1
  6. Maximize the title pane

Notice that Tab 3 and Tab 4 are no longer rendering their content.

Change History (5)

comment:1 Changed 9 years ago by Katie Vance

Component: GeneralDijit

comment:2 Changed 9 years ago by bill

Milestone: tbd1.6
Status: newassigned

Good catch. When "tab 1" is selected TabContainer calls TitlePane.resize() (which is really ContentPane.resize()), and even though the TitlePane is closed ContentPane.resize() tries to resize() it's children.

Besides that bug, there's another problem that opening the TitlePane doesn't resize() the children, even though this may be their first chance to layout. Changing the test case to make the TitlePane initially closed shows this problem.

comment:3 Changed 9 years ago by bill

Description: modified (diff)

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [23276]) Fix problem in layout widget --> TitlePane --> layout widget hierarchy where the nested layout widget's resize() is called while the TitlePane is closed, rather than when it is opened. Fixes #11816 !strict.

comment:5 Changed 9 years ago by bill

(In [23346]) Get ExpandoPane working again after [23276] (refs #11816) and [23340] (refs #12078), !strict.

Reintroduced separate ContentPane._layoutChildren() method since ExpandoPane was referencing it and other classes might be theoretically referencing it too.

Note: See TracTickets for help on using tickets.