Opened 12 years ago

Closed 9 years ago

#11812 closed defect (wontfix)

dojo.create fails to add all attributes of input type=hidden in IE7

Reported by: snapieralski Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: HTML Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

When using dojo.create to add a <input type=hidden> element, the attributes "name" and "value" are not created in IE 7.

The attached file provides an example. To reproduce:

  • Click the "Click me to test" link.
  • Use the debug console to view the DIV. The new 'hidden' element will have a type, but no name or value.

This example is verified to work correctly in IE 8, Firefox 3.5, and Chrome 7 beta. It only breaks on IE 7 (as far as I can tell).

Browser: IE 7 OS: Win XP

Attachments (1)

inputHidden.html (560 bytes) - added by snapieralski 12 years ago.
Sample code showing the problem.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by snapieralski

Attachment: inputHidden.html added

Sample code showing the problem.

comment:1 Changed 11 years ago by Chris Mitchell

Owner: anonymous deleted

comment:2 Changed 10 years ago by bill

Component: GeneralHTML
Owner: set to Eugene Lazutkin

Sounds like the IE6/IE7 limitation where name and value need to be initially specified on the node; they can't be added later. Probably we should close as wontfix? You can workaround it by using toDom() or place() to create the node.

Last edited 10 years ago by bill (previous) (diff)

comment:3 Changed 10 years ago by bill

#15479 is a duplicate of this ticket.

comment:4 Changed 10 years ago by millennium

Shouldn't dojo.create, use toDom() internaly when dojo.isIE < 8 ?

comment:5 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: dojo.create fails to add all attributes of input type=hidden in IE 7dojo.create fails to add all attributes of input type=hidden in IE7

Yes, but not worth fixing now since IE6 and IE7 will soon be obsolete.

Note: See TracTickets for help on using tickets.