Opened 9 years ago

Closed 9 years ago

#11796 closed defect (invalid)

Editor: The link dialog should insert http:// if user doesn't type it

Reported by: dwheeler Owned by: Jared Jurkiewicz
Priority: high Milestone: tbd
Component: Editor Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

The link dialog used to prepend http:// when the user didn't type it. For example, if the user typed "www.google.com", it would convert it to "http://www.google.com".

This is a regression, since it worked in 1.4. See: http://bugs.dojotoolkit.org/ticket/7182

Change History (2)

comment:1 Changed 9 years ago by bill

Owner: set to Jared Jurkiewicz

comment:2 Changed 9 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

You need to end the input with a /<optional file> for it to append http.

It needs the cues to know if it should append or not. www.google.com/xxx.yyy.zzz, etc could also just be references to local files on your system. There is no cue that it's really a hostname/url link.

That's how it has always worked (1.4+). It will try to guess whether it is a local file ref or url, but to do so it needs the cue of the /.

Not a regression.

Note: See TracTickets for help on using tickets.