Opened 9 years ago

Closed 9 years ago

#11761 closed defect (invalid)

Programmatic creation of a text box fails with: this.type.toLowerCase is not a function

Reported by: spidey2099 Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

The application has the requirements for building a text box. This works as specified in 1.4.N. However in 1.5, it fails with the message this.type.toLowerCase is not a function. Examining the code reveals that the call to function, which was not present in 1.4 is present in 1.5. However, it appears that it is not a declared function.

Change History (3)

comment:1 Changed 9 years ago by Adam Peller

Component: GeneralDijit
Owner: anonymous deleted

details, please? test case?

comment:2 Changed 9 years ago by spidey2099

So - I did some more testing and found that in 1.5, the text box expects the paramter "type" to be a string. Consequently it performs a toLowerCase operation on the type object. this.type.toLowerCase().

I was passing in an array and consequently the error appeared. I changed my code to pass in a string and now text boxes are rendered correctly.

So it's not a bug.

comment:3 Changed 9 years ago by liucougar

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.