Opened 9 years ago

Closed 8 years ago

#11693 closed defect (fixed)

[patch]dojox.widget.DynamicTooltip not displaying loaded first time (fixed)

Reported by: Caspar Owned by: dante
Priority: high Milestone: 1.6
Component: DojoX Widgets Version: 1.4.0
Keywords: Cc: dante
Blocked By: Blocking:

Description

Expected behaviour: Tooltip opens, does xhr to get content, shows "Loading..." message, then xhr completes & tooltip opens again to show new content. Subsequent opens correctly show the cached loaded content.

Actual behaviour: Tooltip opens, does xhr to get content, shows "Loading..." message, then xhr completes & tooltip continues to show old content. Subsequent opens correctly show the cached loaded content.

First noticed in 1.4.0 but have not tested in later versions; inspection of code for 1.5 leads me to believe this issue will affect 1.5 as well.

I have attached a patch which I believe fixes this for 1.4.0, but have not tested on any later versions.

Apologies for any inaccuracies in description of expected & actual behaviour & lack of testing on recent versions; this is from memory as I haven't used dynamic tooltip in a while.

Attachments (1)

DynamicTooltip.js.diff (900 bytes) - added by Caspar 9 years ago.
Patch to fix defect

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Caspar

Attachment: DynamicTooltip.js.diff added

Patch to fix defect

comment:1 Changed 9 years ago by Adam Peller

Milestone: 1.5.1tbd
Summary: dojox.widget.DynamicTooltip not displaying loaded first time (fixed)[patch]dojox.widget.DynamicTooltip not displaying loaded first time (fixed)

comment:2 Changed 8 years ago by dante

Milestone: tbd1.6
Status: newassigned

comment:3 Changed 8 years ago by dante

Resolution: fixed
Status: assignedclosed

(In [23608]) fixes #11693 - patch was trivial enough not to ask about CLA, just making it match tooltip behavior. test will still be broken because of #12192 but that will be fixed upstream probably

Note: See TracTickets for help on using tickets.