Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#1169 closed defect (fixed)

The dojo.io upload using the formNode with a return type of "text/xml" doesn't send the request...

Reported by: [email protected] Owned by: James Burke
Priority: high Milestone:
Component: IO Version: 0.3
Keywords: Cc: [email protected]
Blocked By: Blocking:

Description

In version 0.3.1 the dojo.io.bind upload using the formNode property with a return type of "text/xml" doesn't send the request from the browser for either firefox 1.5.0.5 or ie 6.0.29. It works for "text/javascript" and "text/plain".

This can be reproduced by using the http://archive.dojotoolkit.org/nightly/tests/io/test_IframeIO.html example and just change the mimetype from "text/javascript" to "text/xml". I used Live HTTP headers to verify this fact.

Attachments (1)

test2.jsp (1.3 KB) - added by [email protected] 14 years ago.
Altered example to show reproducible test case

Download all attachments as: .zip

Change History (7)

Changed 14 years ago by [email protected]

Attachment: test2.jsp added

Altered example to show reproducible test case

comment:1 Changed 14 years ago by James Burke

Cc: [email protected] added

IframeIO does not support a text/xml return type because there is no good cross-browser way to get the XML document out from an iframe. There is a note about text/xml not being supported in this page:

http://manual.dojotoolkit.org/WikiHome/DojoDotBook/Book24

Perhaps though, what we should fix is how to detect that dojo.io.bind() cannot fulfill the request (right now it will just silently not call IframeTransport?'s bind() method, and just return the dojo.io.Request object). It would be good to at least let the caller know that the bind request is not going to happen.

comment:2 Changed 14 years ago by dylan

Milestone: 0.4
Priority: highnormal
Version: 0.20.3

comment:3 Changed 14 years ago by James Burke

Owner: changed from alex to James Burke

Stealing io and package bugs from Alex. Holler if you want it back.

comment:4 Changed 14 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [5931]) Fixes #1169: now if a transport for a dojo.io.bind() request cannot handle the request, the error callback is called.

comment:5 Changed 14 years ago by James Burke

(In [5932]) References #1169. Tweak for it to work in IE.

comment:6 Changed 13 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.