Opened 9 years ago

Closed 9 years ago

#11688 closed defect (wontfix)

Tab entry freezes

Reported by: Ruth Lang Owned by: anonymous
Priority: high Milestone: tbd
Component: General Version: 1.4.3
Keywords: Tab Control Cc: A.Mueller@…
Blocked By: Blocking:

Description

The problem occurs in Safari and in Chrome.

If you check and uncheck layers in the legend, then you see that the legend part is changing and the layer is visible/unvisible in the map. If you now change the tab to tools and then go back to legend you still see the legend. But if you check/uncheck a layer only the map part is updated but the legend part is not updated it is freezed

For the Tab we use Dojo 1.4 Tab control. The handling is fine with Firefox, Opera and IE (with Adobe SVGViewer)

Thank you for looking at this problem

Armin

Attachments (1)

webkit_testcase.zip (3.0 KB) - added by Ruth Lang 9 years ago.
a small testcase

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by bill

Huh? What legend? What layers? Please attach a test case using the attach file button.

comment:2 Changed 9 years ago by Ruth Lang

Sorry forgot the URL http://www.mappetizer.de/en/examples/schlatterbach/index.html

I am not sure if this is really a Dojo problem or if the problem comes from WebKit?. Unfortunately it is not possible to make a smaller testcase

comment:3 Changed 9 years ago by bill

Looks like a webkit bug to me, assuming it's valid to hide/show an SVG document. I can't do anything in dijit to fix this, maybe you can work around it by recreating the document each time that tab is selected?

comment:4 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed

PS: or, stop using SVG in that tab and just use plain HTML.

Changed 9 years ago by Ruth Lang

Attachment: webkit_testcase.zip added

a small testcase

comment:5 Changed 9 years ago by Ruth Lang

Resolution: wontfix
Status: closedreopened

I have an information from WekKit?, that the problem is that the property display is changed to "none" when changing the tabs. This has the effect that WebKit? kills the renderer and reset all CSS settings. Is it possible to set the display property to "hidden" instead of none? Then Webkit does not has this behavior. I think this behavior could be a problem with other things in tabs too

comment:6 Changed 9 years ago by bill

Resolution: wontfix
Status: reopenedclosed

You can try overriding the definitions of dijitHidden and dijitVisible (CSS classes) to use visibility:hidden instead of display:none, but we did it that way once and IIRC had some other issues on IE6. So I'm not going to change the default behavior.

Note: See TracTickets for help on using tickets.