Opened 9 years ago

Closed 8 years ago

#11681 closed defect (wontfix)

DataGrid, multiple view - rows not aligned when images inserted into cell using formatted

Reported by: evan Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.5
Keywords: datagrid multiple view images Cc: hwcdl@…
Blocked By: Blocking:

Description

When used with multiple views, inserting images to cells(using formatter) makes rows not aligned across views, the attached test case can reproduce this issue.

Explicitly invoking views.renormalizeRow() either not works: e.g.

dojo.connect(views, 'renderRow', function(rowIdx){
     views.renormalizeRow(rowIdx)
});

Need a further look at this.

Attachments (2)

error-#11681.jpg (57.5 KB) - added by evan 9 years ago.
test_grid_column_reorder.html (1.9 KB) - added by evan 9 years ago.
By putting it under dojox/grid/tests/ to see the error

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by evan

Attachment: error-#11681.jpg added

Changed 9 years ago by evan

By putting it under dojox/grid/tests/ to see the error

comment:1 Changed 9 years ago by bill

Owner: changed from bryanforbes to Bryan Forbes

comment:2 Changed 8 years ago by Bryan Forbes

Resolution: wontfix
Status: newclosed

Images from formatters must have an explicit height attribute on them because the DOM won't know the height of the image until it has loaded.

Note: See TracTickets for help on using tickets.