Opened 9 years ago

Closed 9 years ago

#11666 closed defect (fixed)

ItemFileReadStore: first reload doesn't work

Reported by: Douglas Hays Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.6
Component: Data Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

Reloading an ItemFileReadStore? with a new data attribute before any fetches have occurred effectively ignores all reload attempts UNTIL a fetch occurs. The failure testcase is actually on the doc page:
http://dojotoolkit.org/reference-guide/dojo/data/ItemFileReadStore.html#reloading-refreshing-itemfilereadstore-from-a-data-object-dojo-toolkit-1-4
Click the View Example for Reloading/Refreshing? ItemFileReadStore? from a 'data' object (Dojo Toolkit 1.4+)
Without cicking the ComboBox?, click the Reload DataStore? button a couple of times and then click the ComboBox? arrow.
The data shown is the original data and not the reloaded data.
Click te Reload DataStore? button again and then again click the ComboBox? down arrow.
Now the data is new and you can see by the reload count that the data was refreshed several times previously.
The problem is that ItemFileReadStore::_fetchItems is checking for both

this.data != null && this._jsonData == null

when it should only be checking for

this.data != null

since only data is changed by the user during a reload attempt.
IBM #152807

Change History (2)

comment:1 Changed 9 years ago by Douglas Hays

_forceLoad (called by ItemFleWriteStore?) does the same check and most likely needs to change as well

comment:2 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

Fixed in: [22803]

Note: See TracTickets for help on using tickets.