Opened 9 years ago

Closed 8 years ago

#11657 closed defect (worksforme)

IE9 throws exception when _fixEvent (dojo/_base/event.js) attempts to set currentTarget

Reported by: Kenneth G. Franqueiro Owned by: anonymous
Priority: high Milestone: tbd
Component: Core Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

IE9 is apparently suddenly cognisant of event.currentTarget, and doesn't seem to take kindly to it being set; it throws an exception saying "Invalid set operation on read-only property." Currently, _fixEvent sets this as part of the whole cross-browser event normalization routine.

I'm unsure as to what to think as to whether we should code around it, or whether perhaps MS might do something between now and final IE9 release that might resolve it (e.g. efforts to increase back-compat).

The exceptions can be seen e.g. in dijit/tests/test_Dialog.html if you click the first button. I'm sure there's other places this would end up reproduced as well.

Tested in IE9PP 1.9.7916.6000.

Change History (1)

comment:1 Changed 8 years ago by Kenneth G. Franqueiro

Resolution: worksforme
Status: newclosed

This issue seems to be unreproducible as of platform preview 7 (8023.6000) and continues to be unreproducible in the RC (8073.6003). Guess they might've decided this'd cause havoc among UA-sniffing code across the internet?

Note: See TracTickets for help on using tickets.