Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11601 closed defect (fixed)

Calendar: memory leak when using “next month” buttons

Reported by: Roberto Mosqueda Owned by: bill
Priority: high Milestone: 1.5.1
Component: Dijit Version: 1.5
Keywords: memory leak Cc: David Schwartz, [email protected]…, [email protected]…, haysmark
Blocked By: Blocking:

Description (last modified by bill)

Testing Type: Memory leaks

Widget: dijit.InlineEditBox

Short description: Memory level increases when using “next month” buttons. Once you remove them or reload the site memory level keeps higher.

Steps to Reproduce:

  1. Open the file dojo-release-1.5.0/dijit/tests/test_InlineEditBox.html with Safari 4.0
  1. Select a Textbox with a date and click on "next month" button over and over again until arriving to December 2032
  1. Press F5 or reload the page.

Actual Result: Memory used is not released

Expected Result: Memory level should get reduced once you click on a date or when you refresh

Attachments (2)

inlineEditbox.GIF (17.3 KB) - added by Roberto Mosqueda 10 years ago.
11601.patch (1.7 KB) - added by haysmark 10 years ago.
Refs #11601. Reduces the majority of the Calendar memory leak.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Roberto Mosqueda

Attachment: inlineEditbox.GIF added

comment:1 Changed 10 years ago by bill

Cc: [email protected] removed
Component: GeneralDijit
Description: modified (diff)
Owner: anonymous deleted

Is it happening in test_Calendar.html too?

comment:2 Changed 10 years ago by bill

Summary: Memory level increases when using “next month” buttonsCalendar: memory leak when using “next month” buttons

comment:3 Changed 10 years ago by Katie Vance

Cc: haysmark added

comment:4 Changed 10 years ago by haysmark

Yes indeed I also see this on test_Calendar.

Changed 10 years ago by haysmark

Attachment: 11601.patch added

Refs #11601. Reduces the majority of the Calendar memory leak.

comment:5 Changed 10 years ago by haysmark

Per a comment in Calendar, I moved the code where we set the typematic from populateGrid to buildRendering. Because the next month and next year buttons are never removed from the interface, there is no sense in binding them every time the Calendar is updated.

comment:6 Changed 10 years ago by bill

Milestone: tbd1.6
Owner: set to bill

Great, thanks, I'll check that in. Looks to me like the leak is completely fixed.

comment:7 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [22915]) Fixes memory leak from repeated typematic registrations, thanks Mark! Fixes #11601 !strict.

comment:8 Changed 10 years ago by haysmark

Could you also check this in to the 1.5 branch? Also, trac shows the actual change is very large, is this mostly whitespace changes?

comment:9 Changed 10 years ago by bill

(In [22936]) Backport [22915] Calendar memory leak fix to 1.5/ branch, refs #11601 !strict.

comment:10 Changed 10 years ago by bill

Milestone: 1.61.5.1

OK, I backported it to the 1.5 branch.

I think trac showing the change as large is just something weird with trac's diff algorithm? It shows up as a small diff when I compare the two revisions in eclipse. I didn't adjust the spacing at all.

Note: See TracTickets for help on using tickets.