Opened 9 years ago

Closed 9 years ago

#11590 closed defect (worksforme)

TabContainer: memory leak problem when creating a new tab

Reported by: Roberto Mosqueda Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: memory leak Cc: David Schwartz, tmayeur@…, hwcdl@…
Blocked By: Blocking:

Description (last modified by bill)

Testing Type: Memory leaks

Widget: dijit.layout.TabContainer

Description: On Chrome 5, Safari 5 and IE 8 every time you create a new tab, memory is reserved, but when you delete the tab the memory is not released

Steps to reproduce:
1.- Open the affected browser on the dijit/tests/layout/test_TabContainer.html sample page
2.- Open the process explorer tool to monitor the memory used by the affected browser
3.- Click on the "Click to add tab" button several times, and see how the memory is increased.
4.- Click on the close button on each tab to close it, see how the memory is not released.

Actual results: when you create a new tabs, new memory is reserved(image1 attached) but if you close the taba, the memory is not released(image2 attached).

Expected results: if new memory is reserved when a new tab is created, the memory should be released when the tab is closed.

Attachments (2)

image1.jpg (131.1 KB) - added by Roberto Mosqueda 9 years ago.
image2.jpg (130.4 KB) - added by Roberto Mosqueda 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Roberto Mosqueda

Attachment: image1.jpg added

Changed 9 years ago by Roberto Mosqueda

Attachment: image2.jpg added

comment:1 Changed 9 years ago by bill

Cc: bkeese@… removed
Description: modified (diff)
Summary: memory leak problem when creating a new tab in the TabContainer widgetTabContainer: memory leak problem when creating a new tab

It's not really a valid test, since the "add tab" buttton" creates a new ContentPane but closing the tab doesn't delete said ContentPane, but we can take a look.

comment:2 Changed 9 years ago by Douglas Hays

Milestone: tbd1.6
Owner: set to bill

Bill, if you click the down arrow and then click away to close it, and do that over and over, then we are leaking popup menu nodes/iframes. I'm using IE6/sieve to see it.
IBM #151542

comment:3 Changed 9 years ago by bill

I see the iframe leak in trunk... I suppose it's happening for DateTextBox/TimeTextBox too, and perhaps ComboBox, as we keep recreating the drop down. Note that's not related to this ticket though, and also it's a new problem, not something that happened in 1.5.

comment:4 Changed 9 years ago by bill

Filed #11608 for the iframe leak problem.

comment:5 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed

After the iframe fix I'm not seeing any issue. I clicked "add tab" 50 times which did make memory go up (on IE8, it went up about 10M), but after deleting all the tabs it went back down again.

Note: See TracTickets for help on using tickets.