Opened 9 years ago

Closed 8 years ago

#11585 closed defect (invalid)

DataGrid formatter image height bug

Reported by: raspi Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

If formatter inserts image to cell row, height doesn't grow and image is partially cut off and possibly other column data is moved to middle of this new invisible area.

Attachments (2)

dojobug.zip (18.2 KB) - added by raspi 9 years ago.
bug.png (4.5 KB) - added by raspi 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by raspi

Attachment: dojobug.zip added

Changed 9 years ago by raspi

Attachment: bug.png added

comment:1 Changed 9 years ago by raspi

Bug tested with Chrome and FF. zip file contains bug replication in PHP. sleeps mimics the possible slow internet connection in code.

comment:2 Changed 9 years ago by raspi

Might also be related to #10638

comment:3 Changed 9 years ago by raspi

The problem seems to be generated .dojoxGridContent class. It adds style="" attribute with certain height. Other elements before and after that are in correct size.

comment:4 Changed 9 years ago by Adam Peller

Milestone: 1.5.1tbd

comment:5 Changed 9 years ago by bill

Owner: changed from bryanforbes to Bryan Forbes

comment:6 Changed 8 years ago by Bryan Forbes

Resolution: invalid
Status: newclosed

The problem is that the image is still loading when the grid determines the row height and is a know issue with images in the grid. If you specify an image width and height on the image element itself in your formatter, it will fix it.

Note: See TracTickets for help on using tickets.