Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#11574 closed defect (fixed)

dojox.dtl.dom.tag.test_tag_ifequal fails in FF

Reported by: liucougar Owned by: Chris Mitchell
Priority: high Milestone: 1.7
Component: DojoX DTL Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

fail in both FF3.6 and 3.0 (with trunk at r22726)

Change History (5)

comment:1 Changed 9 years ago by liucougar

one workaround is to add the following line

if(key=='value')this._parent.setAttribute(key, value);

after line dojo.attr(this._parent, key, value); in dojox/dtl/dom.js

comment:2 Changed 9 years ago by ben hockey

+1 - the root cause is the whole mess created by dojo.attr not working strictly on attributes.

comment:3 Changed 8 years ago by Chris Mitchell

Owner: changed from Neil Roberts to Chris Mitchell
Status: newassigned

comment:4 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: assignedclosed

(In [25221]) fixes #11574 dojox.dtl.dom.tag.test_tag_ifequal fails in FF \!strict

comment:5 Changed 8 years ago by bill

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.